Stop abbreviating 1,000,000 into 1M

Is there a way to prevent GraphQL queries from returning results abbreviated from 1,000,000 into 1M and 1,000,000,000 into 1G ?
because when they are abbreviated you dont get exact number of amount of tokens transfered, for example this BSC tx Binance Transaction Hash (Txhash) Details | BscScan has total amount of tokens is transfered 389,294,208,481.41733503 tokens but in GraphQL its abbreviated to 389.29G so when doing calculations based on the the abbreviated result returned thats 389,290,000,000 tokens transfered
Thank you

1 Like

You can refer to one of our recent tutorials Getting data in the form of a CSV file from Bitquery GraphQL API using NodeJS

Also in addition to the tutorial link, are you comfortable with sharing your graphql query?

thank you for your reply
its default query actually, I just need to the amount of of token transfered in whole number without abbreviation.

                    query ($network: EthereumNetwork!,
                            $address: String!,
                            $limit: Int!,
                            $offset: Int!
                            $from: ISO8601DateTime,
                            $till: ISO8601DateTime){
                ethereum(network: $network){
                  transfers(options:{desc: "block.timestamp.time"  asc: "currency.symbol" limit: $limit, offset: $offset},
                    date: {since: $from till: $till },
                    amount: {gt: 0},
                    sender: {is: $address}) {

                    block {
                      timestamp {
                        time (format: "%Y-%m-%d %H:%M:%S")
                    address: receiver {
                    currency {
                    transaction {